Multitool.org Forum
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
+-

Hello Lurker! Remove this ad and much more by logging in.


Hm... something seems to be wrong with this Skeletool 1383

No Life Club Posts: 2,549
Hm... something seems to be wrong with this Skeletool
« on: April 13, 2011, 02:20:01 AM »
Trying to undo a stuck leg lock on my camera tripod and *snap*




One of the older PE blade skeletools as well.
Global Moderator Zombie Apprentice Posts: 12,168 North American Meetup: May13-15 2011
Re: Hm... something seems to be wrong with this Skeletool
« Reply #1 on: April 13, 2011, 02:38:42 AM »
Wow, that's a shame, especially since it's the old original configuration. :(

Admin Team Absolute Zombie Club Posts: 23,213
Re: Hm... something seems to be wrong with this Skeletool
« Reply #2 on: April 13, 2011, 02:44:53 AM »
Bummer dude. :(

In order to be certain of having the right tool for every job.........one must first acquire a lot of tools
No Life Club Posts: 1,571
Re: Hm... something seems to be wrong with this Skeletool
« Reply #3 on: April 13, 2011, 03:37:33 AM »
Yikes... poor Skeletool.  :(

This is called a Swiss Army Knife. Do you know what Switzerland is? Switzerland is a place where they don't like to fight, so they get people to do their fighting for them while they ski and eat chocolate. - Larry David
No Life Club Posts: 2,026
Re: Hm... something seems to be wrong with this Skeletool
« Reply #4 on: April 13, 2011, 05:52:35 AM »
Send a letter to LM saying that you want the PE on the replacement,they might just do it for you,good look. :salute:
Absolutely No Life Club Posts: 6,748
Re: Hm... something seems to be wrong with this Skeletool
« Reply #5 on: April 13, 2011, 06:32:50 AM »
Sorry your Skeletool broke.

What? Enablers! Are you serrrrious? Where? I dont see any.
Hold Fast
No Life Club Posts: 4,120 "Survival must be earned"-Klingon Proverb
Re: Hm... something seems to be wrong with this Skeletool
« Reply #6 on: April 13, 2011, 01:47:56 PM »
Leatherman better double check their Rockwell temper rating  :think: :ahhh

"Some rise by sin, and some by virtue fall;
 Some run from breaks of ice, and answer none:
 And some condemned for a fault alone." -William Shakespeare, King Lear (1608), Act IV, scene 6, line 169
Newbie Posts: 49
Re: Hm... something seems to be wrong with this Skeletool
« Reply #7 on: April 13, 2011, 02:54:53 PM »
 :o bummer. Hope that LM takes care of you. Does'nt sound like it was being mis-used.
Newbie Posts: 16
Re: Hm... something seems to be wrong with this Skeletool
« Reply #8 on: April 13, 2011, 05:51:57 PM »
Man that sucks!!

Hope you didn't hurt yourself
Keeper Of The PowerCut Admin Team Zombie Apprentice Posts: 16,886 - Allan

AHB dk

*
Re: Hm... something seems to be wrong with this Skeletool
« Reply #9 on: April 13, 2011, 07:16:51 PM »
Oouch... :-\


"Don't mistake lack of talent for genius."
No Life Club Posts: 2,549
Re: Hm... something seems to be wrong with this Skeletool
« Reply #10 on: April 13, 2011, 09:13:58 PM »
Leatherman better double check their Rockwell temper rating  :think: :ahhh

I actually remember snapped plier heads being a problem with some of the early run skeletools.  I wonder if I just ended up with one of the bad batch.
Full Member Posts: 203
Re: Hm... something seems to be wrong with this Skeletool
« Reply #11 on: April 13, 2011, 09:16:39 PM »
Ah man thats unlucky.
Newbie Posts: 44
Re: Hm... something seems to be wrong with this Skeletool
« Reply #12 on: April 13, 2011, 10:55:13 PM »
Send a letter to LM saying that you want the PE on the replacement,they might just do it for you,good look. :salute:

It worked for me, I love the outcome!

http://forum.multitool.org/index.php/topic,21057.0.html

It still isn't as broken-in as my old one, but I do love it so. It has a big brother MUT i've been meaning to post pics of too... :)

Absolutely No Life Club Posts: 9,733 You're amongst friends.
Re: Hm... something seems to be wrong with this Skeletool
« Reply #13 on: April 13, 2011, 11:34:06 PM »
Leatherman better double check their Rockwell temper rating  :think: :ahhh

I actually remember snapped plier heads being a problem with some of the early run skeletools.  I wonder if I just ended up with one of the bad batch.
From what I've been reading, aren't they all a "bad batch"?  They're supposed to be improving their diecast quality for future productions...

SAW
Hero Member Posts: 601
Re: Hm... something seems to be wrong with this Skeletool
« Reply #14 on: April 14, 2011, 12:40:49 AM »
 :(   just    :(

 

Donations

Operational Funds

Help us keep the Unworkable working!
Donate with PayPal!
September Goal: $300.00
Due Date: Sep 30
Total Receipts: $138.52
PayPal Fees: $8.22
Net Balance: $130.30
Below Goal: $169.70
Site Currency: USD
43% 
September Donations

Community Links


Powered by EzPortal
SMF 2.0.17 | SMF © 2020, Simple Machines
Page created in 0.066 seconds with 33 queries.
© 2018 Defender Web & Tool